Installing Horde Groupware Webmail Edition 4.0

更新日2011-09-01 (木) 16:08:16

事前準備

事前に以下のようなパッケージをインストール

# apt-get install php5-pear
# apt-get install courier-imap
# apt-get install mysql
# apt-get install mysql-client
# apt-get install php5-apache2
# apt-get install php5-mysql
# apt-get install php5-imap

php

php.ini

memory_limit = 512M

32Mだと

HP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allo cate 64 bytes) in /usr/share/php5-pear/PEAR/XMLParser.php on line 171 で「pear install -a -B horde/webmail」のコマンドが止まる

Hordeのインストール

インストールディレクトリ作成

# mkdir /var/www/html/horde

同じようにインストールしようとしたとき原因は不明だが、インストールディレクトリがルートになってしまった。困った。もしかすると事前にaliasを作成しapacheを動作させる必要があるのだろうか?

インストール

# pear channel-discover pear.horde.org
Adding Channel "pear.horde.org" succeeded
Discovery of channel "pear.horde.org" succeeded
# pear install horde/horde_role
downloading Horde_Role-1.0.0.tgz ...
Starting to download Horde_Role-1.0.0.tgz (2,304 bytes)
....done: 2,304 bytes
install ok: channel://pear.horde.org/Horde_Role-1.0.0
horde/Horde_Role has post-install scripts:
/usr/share/php5-pear/PEAR/Installer/Role/Horde/Role.php
Horde_Role: Use "pear run-scripts horde/Horde_Role" to finish setup.
DO NOT RUN SCRIPTS FROM UNTRUSTED SOURCES
# pear run-scripts horde/horde_role
Including external post-installation script "/usr/share/php5-pear/PEAR/Installe r/Role/Horde/Role.php" - any errors are in this script
Inclusion succeeded
running post-install script "Horde_Role_postinstall->init()"
init succeeded
Filesystem location for the base Horde application : /var/www/html/horde
Configuration successfully saved to PEAR config.
Install scripts complete
# pear install -a -B horde/webmail
(ここで少し時間がかかる)
Failed to download pear/SOAP within preferred state "stable", latest release 
is version 0.12.0, stability "beta", use "channel://pear.php.net/SOAP-0.12.0" to install
Failed to download pear/Date_Holidays within preferred state "stable", latest 
release is version 0.21.5, stability "alpha", use "channel://pear.php.net/Date
_Holidays-0.21.5" to install

(略)

horde/Horde_Core can optionally use package "pear/Text_CAPTCHA"
horde/Horde_Db can optionally use PHP extension "mysql"
horde/Horde_Db can optionally use PHP extension "mysqli"
(略)
horde/Horde_Kolab_Format can optionally use package "horde/Horde_Test" 
(version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
downloading webmail-4.0.2.tgz ...
Starting to download webmail-4.0.2.tgz (68,394 bytes)
.................done: 68,394 bytes
downloading content-1.0.2.tgz ...
Starting to download content-1.0.2.tgz (20,335 bytes)
...done: 20,335 bytes
Starting to download Horde_Feed-1.1.0.tgz (1,611,416 bytes)
...done: 1,611,416 bytes

(略)

install ok: channel://pear.horde.org/content-1.0.2
install ok: channel://pear.horde.org/timeobjects-1.0.2
install ok: channel://pear.horde.org/Horde_Form-1.0.4
install ok: channel://pear.horde.org/Horde_Rpc-1.0.2
install ok: channel://pear.horde.org/Horde_DataTree-1.0.0
install ok: channel://pear.horde.org/Horde_Editor-1.0.1
install ok: channel://pear.horde.org/horde-4.0.8
install ok: channel://pear.horde.org/imp-5.0.10
install ok: channel://pear.horde.org/ingo-2.0.4
install ok: channel://pear.horde.org/kronolith-3.0.8
install ok: channel://pear.horde.org/mnemo-3.0.2
install ok: channel://pear.horde.org/nag-3.0.3
install ok: channel://pear.horde.org/turba-3.0.7
install ok: channel://pear.horde.org/webmail-4.0.2
MDB2: Optional feature fbsql available (Frontbase SQL driver for MDB2)
MDB2: Optional feature ibase available (Interbase/Firebird driver for MDB2)
MDB2: Optional feature mysql available (MySQL driver for MDB2)
MDB2: Optional feature mysqli available (MySQLi driver for MDB2)
MDB2: Optional feature mssql available (MS SQL Server driver for MDB2)
MDB2: Optional feature oci8 available (Oracle driver for MDB2)
MDB2: Optional feature pgsql available (PostgreSQL driver for MDB2)
MDB2: Optional feature querysim available (Querysim driver for MDB2)
MDB2: Optional feature sqlite available (SQLite2 driver for MDB2)
MDB2: To install optional features use "pear install pear/MDB2#featurename"

事前DB作成(MySQL)

# mysqladmin -u root create horde
# mysql -u root mysql
mysql> grant select,insert,update,delete,create,drop,index,alter on horde.* 
to hordeuser@localhost IDENTIFIED BY '*******' WITH GRANT OPTION;
Query OK, 0 rows affected (0.00 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

インストール続き

# webmail-install
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/php.ini on line 1907 in Unknown on line 0

Installing Horde Groupware Webmail Edition

Configuring database settings

What database backend should we use?
    (false) [None]
    (mysql) MySQL / PDO
    (mysqli) MySQL (mysqli)
    (pgsql) PostgreSQL
    (sqlite) SQLite

Type your choice []: mysql
Request persistent connections?
    (1) Yes
    (0) No

Type your choice [0]:

Username to connect to the database as* [] hordeuser
Password to connect with  ******* <=パスワード入力
How should we connect to the database?
    (unix) UNIX Sockets
    (tcp) TCP/IP

Type your choice [unix]: tcp

Database server/host* [] localhost

Port the DB is running on, if non-standard [3306]

Database name to use* [] horde

Internally used charset* [utf-8]
Use SSL to connect to the server?
    (1) Yes
    (0) No

Type your choice [0]:

Certification Authority to use for SSL connections []
Split reads to a different server?
    (false) Disabled
    (true) Enabled

Type your choice [false]:

Writing main configuration file... done.

Creating and updating database tables... done. 

Configuring administrator settings 

Specify an existing mail user who you want to give administrator
permissions (optional):

Writing main configuration file... done.

Thank you for using Horde Groupware Webmail Edition!

設定

# cd /var/www/html/horde

http://(host名)/horde/test.phpで確認するには

config/conf.php

$conf['testdisable'] = false;

sendmailのパス変更

$conf['mailer']['params']['sendmail_path'] = '/usr/sbin/sendmail';

# chown -R apache.apache static

http://(host名)/horde/test.phpにアクセスし、赤い文字がないことを確認

Apacheの動作モードの変更

php5-apache2をインストールにより worker MPMからprefork MPM へ変更が必要

# apt-get install php5-apache2 
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
以下の追加パッケージがインストールされます:
  php5 php5-pear
以下のパッケージが新たにインストールされます:
  php5 php5-apache2 php5-pear
アップグレード: 0 個, 新規インストール: 3 個, 削除: 0 個, 保留: 1 個
12.4MB のアーカイブを取得する必要があります。
展開後に 40.3MB のディスク容量が追加消費されます。
続行しますか? [Y/n]
取得:1 http://updates.vinelinux.org 6/x86_64/plus php5-pear 5.3.7-1vl6 [423kB]
取得:2 http://updates.vinelinux.org 6/x86_64/plus php5 5.3.7-1vl6 [8036kB]
取得:3 http://updates.vinelinux.org 6/x86_64/plus php5-apache2 5.3.7-1vl6 [3934kB]
12.4MB を 1s 秒で取得しました (7321kB/s)
変更を適用しています...
準備中                                ############################## [100%]
更新/インストール中
  php5-5.3.7-1vl6.x86_64                 ############################## [100%]
  php5-pear-5.3.7-1vl6.x86_64            ############################## [100%]
  php5-apache2-5.3.7-1vl6.x86_64         ############################## [100%]

 Apache2 is configured to use worker MPM. But php5-apache2 requires
prefork MPM. Run the following command as root to switch MPM:

    /sbin/update-alternatives --config apache2

完了

Apacheのページには

Apache2 の MPM マルチスレッドモードを実運用環境で使用することは推奨されません。
代わりに prefork MPM を使ってください。これは Apache 2.0 および 2.2 における
デ フォルトの MPM です。

とあります

変更

# /sbin/update-alternatives --config apache2

2 プログラムがあり 'apache2' を提供します。

  選択       コマンド
-----------------------------------------------
 + 1           /usr/sbin/apache2.worker
*  2           /usr/sbin/apache2.prefork

Enter を押して現在の選択 [+] を保持するか、選択番号を入力します:2

確認

# /sbin/update-alternatives --config apache2

2 プログラムがあり 'apache2' を提供します。

  選択       コマンド
-----------------------------------------------
   1           /usr/sbin/apache2.worker
*+ 2           /usr/sbin/apache2.prefork

Enter を押して現在の選択 [+] を保持するか、選択番号を入力します:^C

参考


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2011-09-01 (木) 16:08:16 (2577d)