Android/Android Error Memo

更新日2010-04-24 (土) 23:45:20

Error1

以下のよいうなエラーのとき

Project ‘Test’ is missing required source folder: ‘gen’
The project cannot be built until build path errors are resolved
  1. プロジェクトメニューの「Build Automartically」がのはチェックを外す
  2. 「gen」フォルダを削除
  3. 「Claen」を選択してClean all projectsを選択  「Start a build immediately」チェックが入っていれば外す(絶対)
  4. Eclipseをいったん閉じる(絶対)
  5. プロジェクトメニューの「Build Automartically」を有効にする

Error2

以下のよいうなエラーのとき

The method OnClick must override a superclass method

Propertise -> JavaCompiler で 1.6にする

Error3

Androidのバージョン変更により以下のよいうなエラーのとき

R cannot be resolved

「Project」メニュー、「Clean」を実行し、(自動)ビルドすると、R.javaファイルを再作成。
「The type R is already defined」エラーの場合も、R.javaファイルを手動で削除すればOK。

Error4

以下のよいうなエラーのとき

Still no compatible AVDs with target 'Android 2.1': Aborting launch.

Window => Android SDK and AVD Manger で上記の場合 Platform で 2.1 を追加する。

Warning 1

以下のよいうなWARNINGのとき

WARNING: Application does not specify an API level requirement!
Device API version is 3 (Android 1.5)

AndroidManifest.xmlに追加

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
      package="com.example.android.dual"
      android:versionCode="1"
      android:versionName="1.0.0">
    <application android:icon="@drawable/icon" android:label="@string/app_name">
        <activity android:label="@string/app_name" android:name=".Main">
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>
        <activity android:label="@string/app_name" android:name=".Editor"/>
    </application>
    <uses-sdk android:minSdkVersion="3" />    <==ここを追加
</manifest>

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2010-04-24 (土) 23:45:20 (3494d)